If you benefit from web2py hope you feel encouraged to pay it forward by contributing back to society in whatever form you choose!


  • 0
    kkdoc-10636  8 years ago

    Hi Hans Christian,

    which version of reportlab do you prefer?

    I have problems on debian 6.0.5 with build-essential installed:

    easy_install reportlab

    [...]

    Best match: reportlab 2.6

    [...]

    /tmp/easy_install-TdH3sF/reportlab-2.6/src/rl_addons/rl_accel/_rl_accel.c:1280: error: ‘ttfonts_add32L’ undeclared here (not in a function)
    /tmp/easy_install-TdH3sF/reportlab-2.6/src/rl_addons/rl_accel/_rl_accel.c:1281: error: ‘hex32’ undeclared here (not in a function)
    /tmp/easy_install-TdH3sF/reportlab-2.6/src/rl_addons/rl_accel/_rl_accel.c:1282: error: expected ‘}’ before ‘unicode2T1’
     

    error: Setup script exited with error: command 'gcc' failed with exit status 1

     

    replies (1)
    • hcvst 8 years ago

      Hi,

      I installed it quite some time ago. I am running 2.5.

      >>> import reportlab >>> reportlab.Version '2.5'

      But since this is a build error you should be able to find some help. I had a search for '‘ttfonts_add32L’ undeclared here' and it looks like you need to also 'apt-get install' your python-dev first.

      Regards, HC

Commented on:

A module to make using ReportLab a little easier from web2py.

Hosting graciously provided by:
Python Anywhere